Algunos de los contenidos técnicos de este sitio web solo están disponibles en inglés.

Default scheduled jobs in Space

Introducción

Default scheduled jobs are system tasks that are set up to be performed automatically. You can view the scheduled jobs on the system by selecting Tools > Scheduled jobs.

'Scheduled jobs' screen'Scheduled jobs' screen

The three job types below are scheduled on the system by default:

Depending on the status of each job, two icons can be displayed in the Status column on the Scheduled jobs screen. Find a description of these icons in the following table.

IconDescripción
Paused icon
Paused
This icon is shown when a job is paused. You can select the job and click Restart to restart it.
Running icon
Running
This icon is shown when a job is running. You can select the job and click Pause to pause it.

You can change the configuration and scheduling options for the default jobs, or create additional scheduled jobs. If you create an additional scheduled job, you have the option to delete the entry. However, you cannot delete any of the default job types.

Scheduled jobs are not performed when the Space service is not running.

Depuración automática de la pista de auditoría

Audit trail purging removes all audit trail data within a selected time frame from the system. The purged data is saved to a text file in a specified folder location. See Audit Trail for more information about audit trails. Automatic purges of the audit trail are scheduled to be performed every 60 days by default but you can change the configuration and scheduling options for this job.

It is strongly recommended that you purge the audit trail at least once a month. This is because system communication can slow down if the audit trail is full. Regular audit trail purges also allow you to perform more efficient searches on audit trail entries.

The automatic audit trail purging process consists of three steps:

Paso uno: Configuración del trabajo

To complete step one:

  1. Select Tools > Scheduled jobs. The Scheduled jobs screen is displayed.

  2. Click the Automatic purge entry. The Job configuration screen is displayed.

Automatic audit trail purging - 'Job configuration' screenAutomatic audit trail purging - 'Job configuration' screen

  1. The Name of scheduled job and Purge file destination folder fields are automatically populated but you can change the text in these fields if required.

  2. Click on Verify to verify the file directory exists and is correct.

  3. Select a format from the File format drop-down list. This specifies the format of the file containing the purged events. The appropriate format depends on the alphabet you are using. En general, el sistema selecciona el formato requerido por defecto. Sin embargo, puedes modificarlo si es necesario.

  4. Selecciona los parámetros de tiempo necesarios utilizando las flechas arriba y abajo y las opciones en el campo Eliminar eventos anteriores a. Se purgan todos los eventos anteriores a la hora que selecciones.

  5. Haz clic en Siguiente paso. Se muestra la pantalla Programación.

Paso dos: Programación

Para completar el paso dos, haz lo siguiente:

  1. Selecciona el número de días necesario utilizando las flechas arriba y abajo en el campo Frecuencia (días). Si seleccionas 50, por ejemplo, el trabajo se realiza cada 50 días.

Eliminación automática de registros de auditoría - pantalla 'Tareas programadas'Eliminación automática de registros de auditoría - pantalla 'Tareas programadas'

  1. Selecciona la opción Se produce una vez el o la opción Se produce cada y escribe los parámetros de tiempo necesarios para la opción seleccionada. Estas opciones te permiten especificar si el trabajo se realiza una vez el día programado o en intervalos específicos durante ese día.

  2. Selecciona una fecha de inicio para el trabajo utilizando el calendario en el campo Fecha de inicio en el panel Duración.

  3. Selecciona la casilla Fecha de finalización y selecciona una fecha de finalización para el trabajo utilizando el calendario si es necesario. Si no seleccionas una fecha de finalización, el trabajo se realiza indefinidamente.

  4. Haz clic en Siguiente paso. Se muestra la pantalla Confirmación.

Paso tres: Confirmación

Para completar el paso tres:

  1. Revisa la configuración del trabajo y los detalles de la programación en la pantalla Confirmación.

Eliminación automática de registros de auditoría - pantalla 'Confirmación'Eliminación automática de registros de auditoría - pantalla 'Confirmación'

  1. Haz clic en Paso anterior si necesitas modificar la configuración del trabajo y los detalles de la programación o haz clic en Cancelar para descartar todos los cambios de configuración.

  2. Haz clic en Guardar si toda la configuración es correcta y completa.

Copias de seguridad automáticas de la base de datos

Las copias de seguridad automáticas de la base de datos están programadas para realizarse cada siete días de forma predeterminada, pero puedes cambiar las opciones de configuración y programación de este trabajo.

También puedes realizar copias de seguridad de la base de datos utilizando la opción Realizar copia de seguridad de la base de datos.

Se recomienda realizar copias de seguridad de la base de datos una vez a la semana. Esto garantiza que los datos estén actualizados si necesitas restaurar las copias de seguridad del sistema. Las instalaciones grandes pueden optar por realizar copias de seguridad de la base de datos a diario. No debes dejar que transcurra más de un mes entre copias de seguridad. Las copias de seguridad del sistema son el único medio de restaurar el sistema en caso de un fallo total del sistema.

El proceso de copia de seguridad automática de la base de datos consta de tres pasos:

Paso uno: Configuración del trabajo

Para completar este primer paso:

  1. Selecciona Herramientas > Tareas programadas. Se muestra la pantalla Tareas programadas.

'Tareas programadas' pantalla'Tareas programadas' pantalla

  1. Haz clic en la entrada Copia de seguridad automática. Se muestra la pantalla Configuración del trabajo.

Copias de seguridad automáticas de la base de datos - pantalla 'Configuración del trabajo'Copias de seguridad automáticas de la base de datos - pantalla 'Configuración del trabajo'

  1. Los campos Nombre del trabajo programado y Nombre del archivo de copia de seguridad se rellenan automáticamente, pero puedes cambiar el texto de estos campos si es necesario.

  2. Haz clic en Verificar para verificar que el directorio del archivo existe y es correcto.

  3. Haz clic en Siguiente paso. Se muestra la pantalla Programación.

Paso dos: Programación

Todos los pasos de Programación para la sección Tareas programadas predeterminadas se realizan de la misma manera. Consulta Paso dos: Programación para obtener más información y una descripción del procedimiento que debes seguir.

Paso tres: Confirmación

Todos los pasos de Confirmación para la sección Tareas programadas predeterminadas se realizan de la misma manera. Consulte Paso tres: Confirmación para obtener más información y una descripción del procedimiento que debe seguir.

Depuración automática del auditor del sistema

La depuración del auditor del sistema elimina todos los datos del auditor del sistema dentro de un marco de tiempo seleccionado del sistema. Consulte Auditor del sistema para más información. Los datos depurados se guardan en un archivo de texto en una ubicación de carpeta especificada. Las depuraciones automáticas del auditor del sistema están programadas para realizarse cada 60 días de forma predeterminada, pero puede cambiar la configuración y las opciones de programación de este trabajo.

Se recomienda encarecidamente que depure el auditor del sistema al menos una vez al mes. El auditor del sistema se expande a medida que se guardan todos los eventos del operador del sistema, y la comunicación del sistema puede ralentizarse si está lleno. Es importante depurar el auditor del sistema de forma regular si programa trabajos de sincronización automática. Consulte Sincronización automática de archivos CSV y Sincronización automática de tablas de bases de datos para obtener más información.

El proceso de depuración automática del auditor del sistema consta de tres pasos:

Paso uno: Configuración del trabajo

Para completar este primer paso:

  1. Seleccione Herramientas > Tareas programadas. Se muestra la pantalla Tareas programadas.

Pantalla 'Tareas programadas''Tareas programadas' en la pantalla

  1. Haga clic en la entrada Depuración automática del auditor del sistema. Se muestra la pantalla Configuración del trabajo.

Depuración automática del auditor del sistema - Pantalla 'Configuración del trabajo'Purga automática del auditor del sistema - Pantalla 'Configuración del trabajo'

  1. Los campos Nombre del trabajo programado y Carpeta de destino del archivo de depuración se rellenan automáticamente, pero puede cambiar el texto de estos campos si es necesario.

  2. Haga clic en Verificar para verificar que el directorio del archivo existe y es correcto.

  3. Seleccione un formato de la lista desplegable Formato de archivo. Esto especifica el formato del archivo que contiene los eventos depurados. El formato adecuado depende del alfabeto que esté utilizando. En general, el sistema selecciona el formato requerido de forma predeterminada. Sin embargo, puede modificarlo si es necesario.

  4. Seleccione los parámetros de tiempo requeridos utilizando las flechas arriba y abajo y las opciones del campo Depurar eventos más antiguos que. Se depuran todos los eventos anteriores a la hora que seleccione.

  5. Haga clic en Paso siguiente. Se muestra la pantalla Programación.

Paso dos: Programación

Todos los pasos de Programación para la sección Tareas programadas predeterminadas se realizan de la misma manera. Consulte Paso dos: Programación para obtener más información y una descripción del procedimiento que debe seguir.

Paso tres: Confirmación

Todos los pasos de Confirmación para la sección Tareas programadas predeterminadas se realizan de la misma manera. Consulte Paso tres: Confirmación para obtener más información y una descripción del procedimiento que debe seguir.

SALTO SYSTEMS, S. L. utiliza dispositivos de almacenamiento y recuperación de datos de terceros para permitir una navegación más segura y comprender mejor cómo interactúan los usuarios con el sitio web con el fin de mejorar nuestros servicios. Puedes aceptar todas las cookies haciendo clic en el botón "Aceptar cookies" o rechazar su uso pulsando en el botón "Rechazar cookies". Para más información, visita nuestra Política de cookies