Algunos de los contenidos técnicos de este sitio web solo están disponibles en inglés.

Creating scheduled jobs in Space

Introducción

Creating scheduled jobs refers to creating custom jobs. This functionality differs from default scheduled jobs in that default scheduled jobs are preset system jobs. You can create the following types of scheduled job on the system:

When you create a job, it is displayed on the Scheduled jobs screen. The following sections describe how to create these jobs.

Both the synchronization and the export functionalities are license-dependent. See Registering and licensing Space for more information.

Automatic CSV file synchronization

CSV file synchronization allows you to synchronize user data from external system files with Space. For example, in a university installation, you can synchronize with the data in a student record system. You use data from a CSV or a text file to create entries and populate specified fields in Space. This means you can automatically transfer data from other systems (rather than entering the same data manually in Space).

The SALTO_Data_Sync document contains more information about CSV file synchronization. If you don't already have this document, contact your SALTO partner or tech support team to receive a copy of it.

The automatic CVS file synchronization process consists of four steps:

Step one: Job configuration

To complete step one:

  1. Select Tools > Scheduled jobs. The Scheduled jobs screen is displayed.

  2. Click Add. The Add scheduled job dialog box is displayed.

  3. Select CSV file synchronization from the drop-down list.

  4. Click OK. The Job configuration screen is displayed.

CSV job configurationCSV job configuration

  1. Type a name for the job in the Name of scheduled job field.

  2. Type the name of the file that you want to import in the Select file to import/synchronize field. You can click Verify to verify the file directory exists and is correct.

  3. Select the appropriate format from the File format drop-down list.

  4. Select the required number of rows by using the up and down arrows in the Skip rows field. This specifies the row in the file where you want to begin importing data.

  5. Select either the Tabbed or Custom option. The Secondary separator and Text qualifier fields are automatically populated but you can change the characters in these fields if required. The secondary separator is used to separate each access level ID in the file. The text qualifier is used for text fields that contain spaces.

  6. Seleccione la Entidad a importar. Se pueden seleccionar cinco entidades: Usuario, Puerta, Zona, Nivel de acceso del usuario y Operador.

El contenido de los campos puede variar según si está exportando usuarios, puertas, niveles de acceso de usuarios o zonas. Por ejemplo, si está sincronizando o importando puertas, los campos serán los que se encuentran en la lista de puertas.

  1. Selecciona una partición de la lista desplegable Partición si es necesario.

  2. Click en Siguiente paso. Se muestra la pantalla Configuración de la asignación.

Paso dos: Configuración de la asignación

Para completar este paso:

  1. Click en Añadir en la pantalla Configuración de la asignación. El número 1 se muestra en la columna Campos de origen.

  2. Click en la flecha del lado derecho de la entrada para ver la lista desplegable Campos de destino. La opción [No importar] está seleccionada por defecto. Los campos de destino son las opciones de Espacio específicas.

The SALTO_Data_Sync document contains more information about these fields. Si aún no tiene este documento, póngase en contacto con su partner de SALTO o con el equipo de soporte técnico para recibir una copia del mismo.

  1. Select el campo de destino al que desea asignar los datos del campo de origen. La opción seleccionada se muestra en la columna Campos de destino.

Configuración de la asignación CSVConfiguración de la asignación CSV

  1. Repita los pasos 1, 2 y 3 hasta que haya especificado la asignación entre todos los campos de origen y destino y el orden de los campos.

Debe seleccionar la opción ID Ext como uno de los campos de destino para pasar al siguiente paso. El ID de extensión es un ID único que se utiliza para identificar a los usuarios en el sistema. Seleccionar esta opción asegura que los datos del archivo se asocien a los usuarios correctos.

  1. Click en Siguiente paso. Se muestra la pantalla Programación.

Paso tres: Programación

Puede programar la sincronización de archivos CSV para que se realice con la frecuencia que necesite, por ejemplo, cada 24 horas o cada segundo. Todos los pasos de programación de los trabajos descritos en esta sección se realizan de la misma manera. Consulte Paso dos: Programación para obtener más información y una descripción del procedimiento que debe seguir.

Paso cuatro: Confirmación

Todos los pasos de confirmación de los trabajos descritos en esta sección se realizan de la misma manera. Consulte Paso tres: Confirmación para obtener más información y una descripción del procedimiento que debe seguir.

Sincronización automática de tablas de base de datos

La sincronización de tablas de base de datos le permite sincronizar los datos de usuarios de bases de datos externas con la base de datos de SALTO Space. Por ejemplo, en una instalación de una universidad, puede sincronizar con los datos de una base de datos de recursos humanos. Puede acceder a los datos almacenados en una base de datos externa y utilizarlos para crear entradas y rellenar campos específicos en Space. Esto significa que puede transferir automáticamente datos de otras bases de datos (en lugar de introducir los mismos datos manualmente en Space).

The Salto_User_Sync_Staging_Table document contains more information about database table synchronization. Si aún no tiene este documento, póngase en contacto con su partner de SALTO o con el equipo de soporte técnico para recibir una copia del mismo.

El proceso de sincronización automática de tablas de base de datos consta de tres pasos:

Paso uno: Configuración del trabajo

Para completar el Paso uno:

  1. Select Sistema > Tareas programadas. Se muestra la pantalla Tareas programadas.

  2. Click Add. The Add scheduled job dialog box is displayed.

  3. Select DB table synchronization from the drop-down list.

  4. Click OK. The Job configuration screen is displayed.

DB table job configurationDB table job configuration

  1. Type a name for the job in the Name of scheduled job field.

  2. Select the appropriate data source type from the Data source type drop-down list. The available options SQL server, Oracle and ODBC data sources.

  3. Enter the required information in the fields in the Connection parameters panel. The information you must enter in the Connection parameters panel varies depending on which option you select from the Data source type drop-down list. Type the name of the database table in the Table name field. The Separator field is automatically populated but you can change the character in this field if required.

  4. Select the Entity to import. Five entities can be selected: User, Door, Zone, User access level and Operator.

The content of the fields may vary depending on if you are exporting users, doors, user access level or zones. For example, if you are synchronizing or importing doors, the fields will be those found in the door list.

  1. Select a partition from the Partition drop-down list if required. See Partitions for more information about partitions. The data is only imported to the partition you select.

  2. Click Next step. The Mapping configuration screen is displayed.

Step two: Mapping configuration

To complete this step:

  1. Click Add on the Mapping configuration screen. The number 1 is displayed in the Source fields column.

  2. Click the arrow on the right-hand side of the entry to view the Destination fields drop-down list. The [Do not import] option is selected by default. The destination fields are the available SALTO Space database fields to which you can import data. Once imported into the SALTO Space database, the information is then displayed in the appropriate field in Space.

The Salto_User_Sync_Staging_Table document contains more information about these fields. If you don't already have this document, contact your SALTO partner or tech support team to receive a copy of it.

  1. Select the destination field to which you want to map the data from the source field. The selected option is displayed in the Destination fields column.

DB table mapping configurationDB table mapping configuration

  1. Repeat steps 1, 2, and 3 until you have specified the mapping between all the appropriate source and destination fields and the order of the fields. You must select the following options as destination fields to proceed to the next step:
  • Ext ID
  • Control field (to be processed by SALTO)
  • Control field (processed date/time)
  • Control field (error code)
  • Control field (error message)

The system uses these fields to write a report after database table synchronization occurs. If all of these options are not selected, the synchronization job cannot be performed.

  1. Click Next step. The Schedule screen is displayed.

Step three: Schedule

All the schedule steps for the jobs described in this section are done in the same way. See Step two: Schedule for more information and a description of the procedure you should follow.

Step four: Confirmation

All the confirmation steps for the jobs described in this section are done in the same way. See Step three: Confirmation for more information and a description of the procedure you should follow.

Automatic audit trail exports

You can export audit trail data from the SALTO Space database as a CSV file. This allows you to use the data in another system, for example, a time recording system.

When you export audit trail data, you can still access the data in Space as it is not removed. However, when you purge the audit trail, the data is permanently removed from the audit trail and the database.

The SaltoAutomaticExportOfAuditTrail document contains more information about exporting audit trail data. If you don't already have this document, contact your SALTO partner or tech support team to receive a copy of it.

The automatic audit trail export process consists of five steps:

Step one: Job configuration

To complete step one:

  1. Select Tools > Scheduled jobs. The Scheduled jobs screen is displayed.

  2. Click Add. The Add scheduled job dialog box is displayed.

  3. Select Audit trail export from the drop-down list.

  4. Click OK. The Job configuration screen is displayed.

'Job configuration' screen - Audit trail export'Job configuration' screen - Audit trail export

  1. Type a name for the job in the Name of scheduled job field. The default option in the Type of file to export field is CSV file. This is the only file format currently supported.

  2. Type a name for the file that you want to export in the File to export field, such as C:\SALTO\audit-trail, and follow the steps below:

  • Press F2 to display the File path dialog box and insert macros in the file name if required. Using macros, for example, ($YEAR)_($MONTH)_($DAY), allows you to save the file with a unique name so it is not overwritten by the next file that is created.
  • Double-click the appropriate macro to insert it in the file name. Each macro you insert is displayed in the file name in the File to export field.
  • Click OK when you have finished inserting macros and the appropriate file name is displayed in the File to export field.
  • You can click Verify on the Job configuration screen to verify the file directory exists and is correct.

The audit trail export file can be also sent out to a given email by activating the Send file by email option, which will show up three additional fields to fill in:

  • To: The email address the file will be sent to must be defined here.
  • Subject: This field can be filled in with a subject that will be included on the email title.
  • Content: This field can be filled in with a suitable text that will be included on the email body.

The File to export field must be always filled in, and an email server must be configured on the Notifications tab, within the System > General options menu.

  1. Click Next step. The Field configuration screen is displayed.

Step two: Field configuration

To complete step two:

  1. Select a format from the File format drop-down list on the Field configuration screen. This specifies the format of the file containing the exported audit trail data.

  2. Select either the Tabbed or Custom option. This specifies how the audit trail data is stored in the file. The Separator and Text qualifier fields are automatically populated but you can change the characters in these fields if required.

  3. Select the Include column names on first row checkbox if required. If you select this, the column names are included in the first row of the file.

  4. Click Add in the Field configuration panel. The Select fields dialog box, showing a list of fields, is displayed.

'Select fields' dialog box - Audit trail exportation'Select fields' dialog box - Audit trail exportation

The SaltoAutomaticExportOfAuditTrail document contains more information about these fields.

  1. Select the required fields.

  2. Click Accept. The selected fields are displayed in the Fields list on the Field configuration screen.

'Field configuration' screen - Audit trail export'Field configuration' screen - Audit trail export

The order of the fields in the Fields list determines the order in which the fields are exported. You can select fields and click the up and down arrows to change the order of the fields if required.

  1. Click Next step. The Filter configuration screen is displayed.

Step three: Filter configuration

The filter configuration step allows you to filter the type of audit trail data that is exported within a specified time period. The default option is to export all of the audit trail data within the previous 12-month period.

You can filter audit trail events by:

  • Cardholders and/or operators
  • Access points, nodes, alarm inputs, and/or relays
  • Operations
  • Date and time period

'Filter configuration' screen - Audit trail exportation'Filter configuration' screen - Audit trail exportation

To complete this step:

  1. Click Add/Delete in the Who panel. The Add/Delete dialog box, which contains a list of cardholders and operators on two tabs, is displayed.

  2. Select the required cardholders in the left-hand panel and click the arrow. The selected cardholders are displayed in the right-hand panel. You can hold down the Ctrl key while clicking the fields to make multiple selections. As soon as you select a cardholder, the default Any cardholder option is automatically moved to the left-hand panel. You can use the default option if you want to export audit trail data for all the cardholders in the system.

  3. Click the Operators tab if you also want to filter by operator. A list of operators is displayed.

  4. Select the required operators in the left-hand panel and click the arrow. The selected operators are displayed in the right-hand panel.

  5. Click OK. The selected cardholders and operators are displayed in the Who panel.

  6. Follow the same procedure described in the previous steps to add the access points, nodes, alarm inputs, and/or relays you want to filter to the Where panel.

  7. Follow the same procedure described in the previous steps to add the operations you want to filter to the What panel.

  8. Click Add/Delete in the When panel. The Add/delete periods dialog box, showing the default period, is displayed.

  9. Click the Edit icon to change the date period and time interval if required. You can also click Add to add additional periods. For example, you can add a period to export the audit trail data between 09:00 and 11:00 each day within a specified date period, and add another period to export the audit trail data between 14:00 and 17:00 each day within the same date period.

  10. Click OK when you have finished editing or adding periods. The changes are displayed in the When panel.

  11. Click Next step. The Schedule screen is displayed.

Step four: Schedule

All the schedule steps for the jobs described in this section are done in the same way. Consulte Paso dos: Programar para obtener más información y una descripción del procedimiento que debe seguir.

Paso cinco: Confirmación

Todos los pasos de confirmación para los trabajos descritos en esta sección se realizan de la misma manera. Consulte Paso tres: Confirmación para obtener más información y una descripción del procedimiento que debe seguir.

Exportaciones automáticas de entidades

Puede exportar entidades de la base de datos de SALTO Space como un archivo CSV. Esto le permite utilizar los datos en otro sistema, por ejemplo, un sistema de registro de tiempo.

Cuando exporta datos de entidades, aún puede acceder a los datos en Space, ya que no se eliminan.

El proceso de exportación automática de entidades consta de cuatro pasos:

Paso uno: Configuración del trabajo

Para completar el paso uno:

  1. Seleccione Herramientas > Trabajos programados. Se muestra la pantalla Trabajos programados.

  2. Haga clic en Agregar. Se muestra el cuadro de diálogo Agregar trabajo programado.

  3. Seleccione Exportación de entidades de la lista desplegable.

  4. Haga clic en Aceptar. Se muestra la pantalla Configuración del trabajo.

'Pantalla 'Configuración del trabajo' - Exportaciones automáticas de entidades'Pantalla 'Configuración del trabajo' - Exportaciones automáticas de entidades

  1. Escriba un nombre para el trabajo en el campo Nombre del trabajo programado. La opción predeterminada en el campo Tipo de archivo para exportar es Archivo CSV. Este es el único formato de archivo que se admite actualmente.

  2. Escriba un nombre para el archivo que desea exportar en el campo Archivo para exportar, como C:\SALTO\entity-export, y siga los pasos a continuación:

  • Presione F2 para mostrar el cuadro de diálogo Ruta del archivo e insertar macros en el nombre del archivo si es necesario. El uso de macros, por ejemplo, ($YEAR)_($MONTH)_($DAY), le permite guardar el archivo con un nombre único para que no se sobrescriba con el siguiente archivo que se cree.
  • Haga doble clic en la macro apropiada para insertarla en el nombre del archivo. Cada macro que inserte se muestra en el nombre del archivo en el campo Archivo para exportar.
  • Haga clic en Aceptar cuando haya terminado de insertar macros y el nombre de archivo apropiado se muestre en el campo Archivo para exportar.
  • Puede hacer clic en Verificar en la pantalla Configuración del trabajo para verificar que el directorio del archivo existe y es correcto.
  1. Haga clic en Siguiente paso. Se muestra la pantalla Configuración del campo.

Paso dos: Configuración del campo

Para completar este paso:

  1. Seleccione un formato de la lista desplegable Formato de archivo. Esto especifica el formato del archivo que contiene los datos del registro de auditoría exportados.

  2. Seleccione la opción Tabulado o Personalizado. Esto especifica cómo se almacenan los datos del registro de auditoría en el archivo. Los campos Separador y Calificador de texto se rellenan automáticamente, pero puede cambiar los caracteres de estos campos si es necesario.

  3. Seleccione la casilla de verificación Incluir nombres de columna en la primera fila si es necesario. Si selecciona esta opción, los nombres de las columnas se incluyen en la primera fila del archivo.

  4. Haga clic en Agregar en el panel Configuración del campo. Se muestra el cuadro de diálogo Seleccionar campos, que muestra una lista de campos.

'Cuadro de diálogo 'Seleccionar campos' - Exportaciones automáticas de entidades'Cuadro de diálogo 'Seleccionar campos' - Exportaciones automáticas de entidades

The Salto_Data_Export document contains more information about these fields. Si aún no tiene este documento, comuníquese con su socio SALTO o equipo de soporte técnico para recibir una copia.

  1. Seleccione los campos requeridos.

  2. Haga clic en Aceptar. Los campos seleccionados se muestran en la lista Campos en la pantalla Configuración de campos.

La pantalla 'Configuración de campos' - Exportaciones automáticas de entidades'Configuración de campos' - Exportaciones automáticas de entidades

El orden de los campos en la lista Campos determina el orden en que se exportan los campos. Puedes seleccionar campos y hacer clic en las flechas hacia arriba y hacia abajo para cambiar el orden de los campos si es necesario.

  1. Haga clic en Paso siguiente. Se muestra la pantalla Configuración de filtro.

Paso tres: Programación

Todos los pasos de la programación para los trabajos descritos en esta sección se realizan de la misma manera. Consulte Paso dos: Programación para obtener más información y una descripción del procedimiento que debe seguir.

Paso cuatro: Confirmación

Todos los pasos de confirmación para los trabajos descritos en esta sección se realizan de la misma manera. Consulte Paso tres: Confirmación para obtener más información y una descripción del procedimiento que debe seguir.

Exportación automática de inactividad de usuarios

Puede exportar la inactividad de los usuarios desde la base de datos de SALTO Space como un archivo CSV. Esto le permite usar los datos en otro sistema, por ejemplo, un sistema de registro de tiempo.

Los datos de los usuarios también se pueden enviar por correo electrónico. Cuando exporta datos de usuarios, aún puede acceder a los datos en Space, ya que no se eliminan.

El proceso de exportación automática de inactividad de usuarios consta de cuatro pasos:

Paso uno: Configuración del trabajo

Para completar el paso uno:

  1. Seleccionar Herramientas > Trabajos programados. Se visualiza la pantalla Trabajos programados.

  2. Haga clic en Agregar. Se visualiza el cuadro de diálogo Agregar trabajo programado.

  3. Seleccionar Exportación de inactividad de usuarios en la lista desplegable.

  4. Hacer clic en Aceptar. Se visualiza la pantalla Configuración del trabajo.

Pantalla 'Configuración del trabajo' - Exportación automática de inactividad de usuarios'Configuración del trabajo' - Exportación automática de inactividad de usuarios

  1. Escriba un nombre para el trabajo en el campo Nombre del trabajo programado. La opción predeterminada en el campo Tipo de archivo a exportar es Archivo CSV. Este es el único formato de archivo compatible actualmente.

  2. Escriba un nombre para el archivo que desea exportar en el campo Archivo a exportar, por ejemplo, C:\SALTO\users-inactivity, y siga los pasos a continuación:

  • Presione F2 para visualizar el cuadro de diálogo Ruta del archivo e insertar macros en el nombre del archivo si es necesario. El uso de macros, por ejemplo, ($YEAR)_($MONTH)_($DAY), le permite guardar el archivo con un nombre único para que no se sobrescriba con el siguiente archivo que se cree.
  • Haga doble clic en la macro correspondiente para insertarla en el nombre del archivo. Cada macro que inserta se visualiza en el nombre del archivo en el campo Archivo a exportar.
  • Haga clic en Aceptar cuando haya terminado de insertar macros y se visualice el nombre de archivo correspondiente en el campo Archivo a exportar.
  • Puede hacer clic en Verificar en la pantalla Configuración del trabajo para verificar que el directorio de archivos existe y es correcto.
  1. Haga clic en Paso siguiente. Se visualiza la pantalla Configuración de campo.

Paso dos: Configuración del campo

Para completar el paso dos:

  1. Seleccionar un formato en la lista desplegable Formato de archivo. This specifies the format of the file containing the exported audit trail data.

  2. Select either the Tabbed or Custom option. This specifies how the audit trail data is stored in the file. The Separator and Text qualifier fields are automatically populated but you can change the characters in these fields if required.

  3. Select the Include column names on first row checkbox if required. If you select this, the column names are included in the first row of the file.

  4. Click Add in the Field configuration panel. The Select fields dialog box, showing a list of fields, is displayed.

'Select fields' dialog box - Automatic users inactivity exportation'Select fields' dialog box - Automatic users inactivity exportation

The Salto_Data_Export document contains more information about these fields. If you don't already have this document, contact your SALTO partner or tech support team to receive a copy of it.

  1. Select the required fields and click OK. The selected fields are displayed in the Fields list on the Field configuration screen.

'Field configuration' screen - Automatic users inactivity exportation'Field configuration' screen - Automatic users inactivity exportation

The order of the fields in the Fields list determines the order in which the fields are exported. You can select fields and click the up and down arrows to change the order of the fields if required.

  1. Click Next step. The Schedule screen is displayed.

Step three: Schedule

All the schedule steps for the jobs described in this section are done in the same way. See Step two: Schedule for more information and a description of the procedure you should follow.

Step four: Confirmation

All the confirmation steps for the jobs described in this section are done in the same way. See Step three: Confirmation for more information and a description of the procedure you should follow.

SALTO SYSTEMS, S. L. utiliza dispositivos de almacenamiento y recuperación de datos de terceros para permitir una navegación más segura y comprender mejor cómo interactúan los usuarios con el sitio web con el fin de mejorar nuestros servicios. Puedes aceptar todas las cookies haciendo clic en el botón "Aceptar cookies" o rechazar su uso pulsando en el botón "Rechazar cookies". Para más información, visita nuestra Política de cookies